[TUTORIAL] libro de visitas con MySQL y PHP (muy facil ;))

Como lo prometi, el tuto del libro de visitas, paso a paso...

Bien, hoy vamos a montar un libro de visitas con MySQL no os asusteis, no es tan dificil como muchos lo hacen parecer ;)

Primero vamos a descargar los archivos del guestbook para hacer mas sensillo el tuto

http://rapidshare.com/files/128529731/Guestbook.zip.html

Bueno, una vez que descarguemos los descomprimimos a un directorio, prferiblemente que tenga de nombre guestbook (para poder seguir mas facilmente el tutorial)

Los Archivos seran:

../

index.php
guestbook.sql

../admin

guestbook.php
index.php
schimbapass.php
style.css

../admin/inc/

connect.php
functions.js

Bueno los archivos mas importantes de todos estos son 2

guestbook.sql

connect.php

el primero, es el archivo que contiene las instrucciones para crear la base de datos y es lo primero que vamos a hacer en mi caso, utilizare 000webhost

Primero, entrare a mi panel de control:

[contenido no disponible]
[contenido no disponible]

luego entrare en MySQL y creare una nueva Base de Datos a la que llemare

a8551709_use

con usuario

a8551709_use

Definire mi contraseña

********* ;)

y le dare, "crear base de datos"

Luego, voy a volver a panel de control y voy a seleccionar phpMyAdmin

[contenido no disponible]
[contenido no disponible]

Me dirijo a mi base de datos que acabo de crear y le doy "Enter phpMyAdmin"

[contenido no disponible]
[contenido no disponible]

Esto me va a enviar a la ventana donde administro las tablas de la base de datos ahi nos dirigiremos a SQL para hacer una consulta

[contenido no disponible]
[contenido no disponible]

una vez en esta pantalla, abriremos con notepad el archivo

guestbook.sql

y veremos algo como esto:

CREATE TABLE `users` (
  `id` int(10) NOT NULL auto_increment,
  `user` varchar(25) default NULL,
  `pass` varchar(50) default NULL,
  PRIMARY KEY  (`id`)
) TYPE=MyISAM AUTO_INCREMENT=0 ;

-- 
-- Dumping data for table `users`
-- 

INSERT INTO `users` VALUES (1, 'root', '63a9f0ea7bb98050796b649e85481845');

lo copiaremos y lo pegaremos en el cuadro para la consulta SQL y le daremos "GO"

[contenido no disponible]
[contenido no disponible]

Una vez que nos diga que la tabla ha sido creada satisfactoriamente, veremos algo como esto:

[contenido no disponible]
[contenido no disponible]

cuando hayamos hecho esto, vamos a nuestra carpeta ../admin/inc/ y abrimos con notepad el archivo

connect.php

y veremos algo como esto:

<?

$hostname="localhost"; 
$database="user";
$username="";
$password="";

mysql_connect($hostname, $username, $password) or die (mysql_error());
mysql_select_db($database) or die (mysql_error()); 

?>

nosotros ingresamos nuestros datos:

<?

$hostname="mysql2.000webhost.com"; 
$database="a8551709_use";
$username="a8551709_use";
$password="*******";

mysql_connect($hostname, $username, $password) or die (mysql_error());
mysql_select_db($database) or die (mysql_error()); 

?>

Ojo, ingresen SUS datos ;)

bueno ahora subimos todos nuestros archivos por FTP a nuestro servidor, recomiendo dentro de un directorio que se llame guestbook, una vez que subimos los archivos vamos a poner en nuesto navegador

http://tudominio.com/guestbook/index.php

y veremos algo como esto:

http://nadaquehacer.net46.net/guestbook/index.php

este es un ejemplo del guestbook ya funcionando, aqui podemos ver que todo esta en orden

para borrar o administrar los mensajes, podemos dirigirnos a:

http://tudominio.com/guestbook/admin/index.php

ahi se te pedira un usuario y una contraseña, para poder entrar, la que esta por defecto es

user: root
password: root

SUGERENCIA: cambienla

bueno, eso es todo, ya tienen su libro de visitas con MySQL funcionando en su web, espero que os haya servido, saludos y recuerden visitar el foro de:

http://mzstudios.net46.net

donde publicare nuevos tutoriales como este principalmente en el foro

cualquier problema que tengan con los archivos, me avisan, saludos... :wink:
8) 8) 8) 8) Buen tutorial, pero esta en la seccion equivocada, para eso existe una seccion de tutoriales. 8) 8) 8)
Hola yo tengo uan duda, he estado probando como hacer un libro de visitas. todo sale bien, hago la base de datos, el php, todo bien pero me marca no database selected, y es que en connect.php

<?

$hostname="localhost";
$database="user";
$username="";
$password="";

mysql_connect($hostname, $username, $password) or die (mysql_error());
mysql_select_db($database) or die (mysql_error());

?>

no se que poner en $hostname ?

debe ser una bobada pero no se :cry:
bueno despues de varios intentos con el libro de visitas no me sale..
todo lo hago bien.. de echo tengo que modificar el nombre de la tabla.. creando dos tablas una con nombre users y la otra con nombre guestbook..
ii si me aparece todo.. hasta donde firmar.. solo que cuando le doy submit me salta un error "Column count doesn't match value count at row 1" y de ahi ya no se que hacer.. segun yo todo lo tengo bien..

por favor ayudame..
fue muy buena tu colaboracion.. ya que fue un tuto muy sencillo i facil..
pero estoy atorado en ese paso..
porfavor.. ayuda..
gracias de antemano..
reymolina123 escribió:todo bien pero lo unico que al querer ir a la zona
http://reymolina.atwebpages.com/guestbook/index.php

me dice

Table '226978_reymolina.guestbook' doesn't exist

si alguien save algo de este problema que me lo comunique

Hola a todos, segui los pasos del tutorial hasta que llegue al error que reymolina123 menciona :(
Cuando me dirigo a index me dice
Table 'a1535766_user.guestbook' doesn't exist

Me podeis decir que e hecho mal ?
Segui todos los pasos T_T

Para amarlatierra Tenia el mismo problema que tu y no lo encontraba por ninguna parte ... pero al final lo encontre :D

dirigete a Manage MySQL Databases
y veras como en negrita te pone tu direccion, por ejemplo a mi me pone

mysql9.000webhost.com



Bueno gracias a todos :)
MI problema si mal no creo es que el server no acepta mas base de datos es decir que el sql o el mismo server no acepta ma eo e lo que entendi porqeu e intentado trabajar con mas base de datos de otras aplicaciones y tampoco no me lo permite alguien que me lo aclare
http://reymolina.atwebpages.com/principal.html

os dejo l direccion ese es el servidor con que trabajo bueno puede cer esa la causa pero no estoy muy claro
Hola,

Tengo un pequeño lio con los archivos que tengo que crear en mi servidor local, y los que tengo que subir.

Os ruego me echeis una mano

Gracias

Pedro
He intentado todo los que dices y al final me dice acceso denegado a mi usario de webhost y a la base de datos user ¿Que debo hacer?Respondeme rapido,me urge.
Aclara más los pasos ,por favor.
Las tablas guestbook,ac_users no las creo,solo creo la de 'users'
Un saludo

Como cambio los permisos a tablas,base de datos??????
He intentado todo los que dices(tenga bas de datos,he creado la tabla users en phpmyadmin,he configurado solo esos dos archivos que indicas,los he subido con filezilla a mi servirdor remoto webhost,,accedo a la direccion parecida a la tuya para abrir el libro de visitas,...) y al final me dice acceso denegado a mi usario de webhost y a la base de datos user ¿Que debo hacer?Respondeme rapido,me urge.
Aclara más los pasos ,por favor.
Las tablas guestbook,ac_users no las creo,solo creo la de 'users'
Un saludo

Como cambio los permisos a tablas,base de datos??????


Al clicar en libro de visitas (instalado en joomlaq 1.5) me sale esto:
http://error404.000webhost.com/?



nota:previamente he instalado phocaguesbook en joomla 1.5 ¿interfiere?
He echo todos los paso y al final:

Access denied for user '*****'@'**.**.*.**' to database 'user'

Ni si quiere puedo ingresar root root en donde dices.

Oculto mis datos por seguridad,pero creo que ya sabes de que datos hablo:
color darkred:el nombre de mi username de webhost
color lime:no se que es
Debes poner tu nombre de usuario y contraseña del mysql y no root root.
Es facil programar "Solo interesate en aprender"
Ni si quiera he necesitado esto:"Debes poner tu nombre de usuario y contraseña del mysql y no root root"
He desactivado las paginas amigables y funciona de lo lindo con mi phocabook en joomla 1.5 remoto.No es necesario instalar esto que dices en el tutorial.Me quedo sin paginas amigables pero me funciona mi lista de visitas.
Gracias por tu ayuda
Un saludo.
Por favor,a ver si me pone un tutorial para subir mi joomla local a un servidor remoto.Necesito que sea webcindario o 000webhost.
antes k nada te agradesco tus tutoriales me an sido de muchisisisma ayuda kreo k no ubier alogrado tanto sin ti grasias pero en este si ya no entendi algo ISE TODO LO K DICE SOLO NO ENTENDI ESO DE SUBIR TODO POR FTP OK SE DE LO K HABLAS PERO YA ASI NOMAS ESO ISE LO SUBI A MI HOSTIN O KE ADONDE ALOMEJOR MI PREGUNTA ES TONTA PERO ESA PARTE NO LA AENTIDO I YA AORA STARA EN MI PAGINA???? AYUDA PORFAVORRRRRR
AAA TMB AORA K SUBI AMI HOSTIN TODOS LOS ARCHIVOS DEL guestbook KUANDO INTENTO ABRIR MI PAGINA APARRESE ESTO AUXILIO NESSITO AYIDA Warning: include_once(admin/inc/connect.php) [function.include-once]: failed to open stream: No such file or directory in /home/a6828278/public_html/index.php on line 10