ZWeb Publisher CMS Ayuda

Hola después de un montón de no estar por aquí regreso, aquí hice mi primera web :D.

Bueno mirad yo empece una pagina para un proyecto profesional, me vino la idea que me gustaría ver noticias en mi web ya sabes de esas que se mueven y van saliendo una tras otra, probé con el cutenews pero parece algo viejo sin contar que no sabia que hacer con el código .php, descubri por hai buscanod ota palabra "gestor de contenido web" y de ahí vino lo de pagina dimanica y MySQL y PHP.

luego encontré "ZWeb Publisher CMS" que es es "un sistema gestor de contenidos que le permite mantener fácilmente sus páginas web, blogs, artículos web, etc. Es completamente gratis, freeware". aki su pagina
http://www.ziclope.net/gestor-de-contenidos-web-gratis.htm

el primer paso es subir la base de datos que te dan a mi servidor que es este "eshost.es" soporta MYsql y php pero cuando lo subo me sale esto:
Error
consulta SQL:

--
-- Create schema zweb_db
--
CREATE DATABASE IF NOT EXISTS zweb_db;


MySQL ha dicho:

#1044 - Access denied for user 'eshos_11112045'@'%' to database 'zweb_db'


pregunto sera por que no tengo el permiso de "crear" bases de datos??? que servidores si lo dan ?? o alguien que me de una pista :D gracias .
Hola:

sera por que no tengo el permiso de "crear" bases de datos???

Eso es exactamente tu problema.

que servidores si lo dan

Hasta donde sé, todos los servidores te dan la posibilidad de crear bases de datos, pero con ciertas limitaciones. Si el hosting es pagado y tienes un dominio propio, lo más probable es que puedas crear una base de datos con el nombre que se te antoje, pero si el hosting es gratuito, puede que sólo puedas crear una base de datos con el nombre de tu usuario o con números y letras que no significan nada.

La solución es crear la base de datos manualmente a través de PHPMyAdmin (crea una base de datos con el nombre zweb_db si es que puedes, si no puedes, entonces crea una base de datos cualquiera y anota el nombre de la base de datos para los siguientes pasos). Luego tendrás que modificar el archivo que arroja el error y cambiar las siguientes líneas:

CREATE DATABASE IF NOT EXISTS nombre_base_datos;
USE nombre_base_datos;

Después de modificar el archivo, guárdalo y luego intenta instalarlo nuevamente. El archivo, si es que no sabes cual es, debe tener un nombre como install.sql. No te puedo asegurar nada, pero generalmente la extensión es .sql.

Saludos.
Hola muchas gracias por tu pronta respuesta , hice lo que me dijiste hasta subí un vídeo para que los demás vean http://www.youtube.com/watch?v=xU0myF4kMi8&feature=youtu.be
se ve borroso la mayor parte del tiempo pero se entiende (es que nunca había grabado nada de la pantalla)

bueno primero el server si es el servicio gratis así que primero hice mi base de datos luego entre al admin y en vez de importar el archivo SQL lo abrí en mi pc copie todo y lo pegue y modifique lo que me has dicho son las primeras lineas y luego pude notar que ya estaba donde dice estructura.

el siguiente paso es subir lso archivos a mi servidor .php y modificar no se que cosa así que me tendrás aqui pronto jajajajaaa

saludos
Jajajajajaja, muy bueno.

Solo hay un error mio: si creas la base de datos a través de phpmyadmin, entonces no era necesario modificar la línea CREATE DATABASE IF NOT EXISTS nombre_base_datos porque sí existirá XD (aunque no pasará nada si se modifica).

Lo otro es aclarar que lo que comienza con dos guiones (--) son comentarios y se ignoran al importar el archivo a la base de datos.

Ya no deberías tener problemas, así que espero que no vuelvas (en el buen sentido de la palabra :P).

Saludos :D.