localhost: mis proyectos .php no los abre, pero sí los .html

Por favor, por favor, no pueeeeeeedo con la vida...
Ni firefox ni chromium ni nada me abre archivos php en localhost.

Estos días he tenido que instalar Ubuntu de nuevo, el 14.04 LTS.
Por consiguiente también he tenido que instalar el servidor (desde el Synaptic):
- php5
- apache2
- mysql-server
- mysql-client
- phpmyadmin

Y, como he dicho, el problema es que el navegador abre .html pero .php no lo hace

He probado algunas cositas en la terminal pero no he conseguido nada.

En la versión anterior metía mis proyectos en var/www/
Pero para que funcione en esta nueva versión parece que hay que meterlos sí o sí en var/www/html
¿Puede que haya algún cambio más y yo no lo sepa?

Muchas gracias de antemano, espero haber hecho bien mi pregunta, un saludo a tod@s,
Miriam

http://carteleracallejera.com/index.php
Hola!

Haz esto:

1.- Abre la consola (Control + Alt + T).
2.- Ejecuta sudo a2enmod php5 y presiona enter. Esto habilitará PHP5 si es que no está habilitado.
3.- Reinicia apache: sudo service apache2 restart.

Teóricamente ahora debería funcionar. Si aún no funciona, entonces tienes problemas en la configuración. La configuración debería estar en /etc/apache2/mods-enabled/php5.conf, la cual puedes editar así: sudo gedit /etc/apache2/mods-enabled/php5.conf (si se abre una página en blanco es porque el archivo no se encuentra).
¿No te muestra ningún mensaje al iniciar el servidor utilizando la consola?

Publica los mensajes de los siguientes archivos (si es que existen):

/var/logs/apache2/error.log
/var/logs/php5/error.log

Puede que sean los permisos de los archivos, lo que quizás no tienen permisos para ejecutarse. Para estar seguro, ejecuta lo siguiente:

cd /var
chmod -R 755 www/

Esto es para que los archivos tengan permisos de ejecución y lectura por todos, pero solo el creador (root o tu usuario) puedan editarlos.

Para saber dónde debes poner tus archivos, revisa la configuración de los archivos que hay dentro de /etc/apache2/sites-available y/o /etc/apache2/sites-enabled (lo que hay en esta carpeta son simplemente enlaces simbólicos hacia /etc/apache2/sites-available).
Hola skaparate!

Sigo sin saber qué pasa pero si no estuvieras tan lejos te comería a besos por el apoyo que me estás dando. Muchas muchas gracias!

En fin... Vamos por partes. Tengo este archivo /var/log/apache2/error.log y contiene muchas líneas pero básicamente creo que sólo con mostrarte una ya vale:
[Sat Jul 19 18:31:04.816933 2014] [:error] [pid 2549] [client 127.0.0.1:60454] PHP Parse error: syntax error, unexpected end of file in /var/www/html/mirimPiri/head.php on line 1139

¿Qué le pasa al head.php? Antes de tenerlo que formatear funcionaba perfectamente, con exactamente los mismos archivos. Y si no se conectara con la base de datos me lo diría en un mensaje.

He hecho una prueba:
- he creado prueba.php
- dentro del archivo he escrito <?php echo "Ahí va el php"; ?>
- el navegador me muestra lo siguiente: Ahí va el php

Ya le había dado permisos a los archivos pero por si acaso se los he vuelto a dar, y nada.

Muchas gracias y un saludo bien grande,
Miriam
Bueno, creo que me he centrado en lo que yo pensaba que era un problema y parece que no es eso lo que debo arreglar.

Resulta que el navegador sí que me abre bien otros proyectos que tengo de php.

Entonces por qué no me abre ¡pre-ci-sa-mente! el proyecto en el que estoy trabajando yo ahora??? Y es una copia rescatada de otro disco duro, exacta, que funcionaba perfectamente. Está bien conectado a la base de datos. En el navegador sale en blanco, no entiendo nada... Supongo que lo tendré que averiguar con el método ensayo-error. Tiene que ser una chorradita en la que no caigo. Llevo dos días. Loca me volveré! Loooca... :confused: Qué es lo que se me escapa?

Saludos a tod@s y gracias a quien se apiade de mí y me de una pista.
Sigo sin saber qué pasa pero si no estuvieras tan lejos te comería a besos por el apoyo que me estás dando. Muchas muchas gracias!

De nada, para eso esta el foro :).

El problema te lo da el registro de errores:

[Sat Jul 19 18:31:04.816933 2014] [:error] [pid 2549] [client 127.0.0.1:60454] PHP Parse error: syntax error, unexpected end of file in /var/www/html/mirimPiri/head.php on line 1139

Aquí dice que en la línea 1139 del archivo head.php se encontró el fin de la línea pero se esperaba otra cosa. Esto quiere decir que:

- Te faltó un punto y coma después de la definición o asignación de una variable. Por ejemplo: $mi_variable = "contenido" // <--- falta el punto y coma (;).
- Faltó un corchete/llave o un paréntesis. Algo como: if( $condicion { // hacer algo... } o function mi_funcion( $parametros ) { // hacer algo .... // olvidé el cierre de corchete.
- Falta la etiqueta de cierre de PHP: <?php ?> // ?> Esta última.
- No se cerraron bien las comillas: 'contenido de la cadena; // falta una comilla simple
"contenido de la cadena; // Falta la comilla de cierre.

Esos, entre otros, son los posibles errores. Si quieres no encuentras el error, publica el código de head.php y lo revisamos a ver si encontramos el error. A veces los ojos de los demás ven los errores que se nos pasan (mucho tiempo haciendo lo mismo nos hace obviar los errores más simples - experiencia propia xD).

Saludos!

PD: puede que el error no este en el head.php, también puede estar en los archivos incluidos en este otro, o sea, si no encuentras el error en este archivo, entonces revisa los archivos include|require[_once]("nombre_archivo.php")
skaparate escribió:Aquí dice que en la línea 1139 del archivo head.php se encontró el fin de la línea pero se esperaba otra cosa. Esto quiere decir que:

- Te faltó un punto y coma después de la definición o asignación de una variable. Por ejemplo: $mi_variable = "contenido" // <--- falta el punto y coma (;).
- Faltó un corchete/llave o un paréntesis. Algo como: if( $condicion { // hacer algo... } o function mi_funcion( $parametros ) { // hacer algo .... // olvidé el cierre de corchete.
- Falta la etiqueta de cierre de PHP: <?php ?> // ?> Esta última.
- No se cerraron bien las comillas: 'contenido de la cadena; // falta una comilla simple
"contenido de la cadena; // Falta la comilla de cierre.

Efectivamente!! En una línea del head.php tenía <? en vez de <?php

Ya la veo, siiiii... por fin! Eres un genio skaparate!!

CASO RESUELTO