Problema redireccionamiento con Prestashop

Hola!

¿Podrías publicar el .htaccess? El error debería estar ahí. También revisa el registro de errores de PHP (y cualquier otro registro al que tengas acceso).
Hmmm... el htaccess está bien. Básicamente, en algún lugar de la configuración o los DNS, estás haciendo una "redirección" que hace que prestashop no pueda encontrar las rutas correctas. ¿Es posible que exista otro .htaccess? ¿Por qué mencionas _htaccess y no .htaccess? Lo correcto es .htaccess, a no ser de que tu hosting requiera _htaccess.

Revisa nuevamente los valores de la configuración en la base de datos o publicalos acá, junto con la estructura de carpetas, para ver si hay alguna discrepancia o error.
skaparate escribió:Hmmm... el htaccess está bien. Básicamente, en algún lugar de la configuración o los DNS, estás haciendo una "redirección" que hace que prestashop no pueda encontrar las rutas correctas. ¿Es posible que exista otro .htaccess? ¿Por qué mencionas _htaccess y no .htaccess? Lo correcto es .htaccess, a no ser de que tu hosting requiera _htaccess.

Revisa nuevamente los valores de la configuración en la base de datos o publicalos acá, junto con la estructura de carpetas, para ver si hay alguna discrepancia o error.

Tienes razón, perdone usted. El archivo es .htaccess, lo escribí mal, pero sólo hay uno en la carpeta principal.

Como he comentado anteriormente la web funciona bien con otro dominio, pero al cambiarlo ha dejdao de funcionar.
Lo único que se me ocurre es que no hayas cambiado las URL del archivo settings.inc.php y/o de la base de datos. Revisa los pasos que indican acá por si es que te faltó algo.
Creo que el problema está en el hosting, aunque he llamado y me dicen que como la instalación de prestashop la he realizado yo por mi cuenta no pueden hacerse responsables de lo que haya tocada, pero como decía, creo que el problema e del hosting porque he realizado una instalación nueva y limpia de prestashop y desde el dominio www.visionled.es no accede, la isntala, pero no puedo acceder al frontend.
skaparate escribió:Lo único que se me ocurre es que no hayas cambiado las URL del archivo settings.inc.php y/o de la base de datos. Revisa los pasos que indican acá por si es que te faltó algo.

Todo revisado y todo OK, pero sigue sin funcionar

:(
Es posible que sea problema del hosting, pues al buscar en google al respecto, hay varios resultados que hablan sobre este problema, aunque desafortunadamente están en alemán, idioma que no hablo :P.

Usan CPanel? Si es así, deberías poder acceder a los registros de errores en algún lugar del panel (no recuerdo dónde).

Otra cosa que puedes tratar es buscar en todas las tablas si existe alguna referencia al dominio antiguo. PHPMyAdmin permite hacer una búsqueda en todas las tablas de una base de datos, si es que tienes acceso a este. Después sería cosa de reemplazar todos los resultados por los del nuevo dominio.
skaparate escribió:Es posible que sea problema del hosting, pues al buscar en google al respecto, hay varios resultados que hablan sobre este problema, aunque desafortunadamente están en alemán, idioma que no hablo :P.

Usan CPanel? Si es así, deberías poder acceder a los registros de errores en algún lugar del panel (no recuerdo dónde).

Otra cosa que puedes tratar es buscar en todas las tablas si existe alguna referencia al dominio antiguo. PHPMyAdmin permite hacer una búsqueda en todas las tablas de una base de datos, si es que tienes acceso a este. Después sería cosa de reemplazar todos los resultados por los del nuevo dominio.

Me pongo con ello y te cuento........aunque trasteando bastante un poco de todo he dado con lo siguiente (a ver si os guio un poco) en el dominio www.visionled.es tengo activado el SSL, asi pues lo puse asi antes de hacer el redireccionamiento, pero acabo de encontrar un pestaña en la que pone asignar SSL a todas las páginas, lo he activado y ahora el home me sale en blanco, pero por lo menos no me da ningún error, o porlo menos no se ve....voy a seguir indagando.

Gracias
Actualizo situación...............

Si quereis comprobar, al acceder a www.visionled.es no se ve nada, página en blanco, pero sin errores porque ya cambie a: define('_PS_MODE_DEV_', true); pero en cuanto que accedemos a cualquier parte de la web, aunque sea entrando por un error 404, a partir de ahi mientras no le demos al logo que nos mande al home...la web funciona perfectamente......

Ya vamos prosperando.
Cuál es la estructura de tus carpetas? Tienes la tienda en una carpeta directamente bajo htdocs o todos los archivos de prestashop directamente en htdocs (o public_html u otro)? Además de la tienda tienes un sitio web en el mismo dominio?

P.D: Una solución es instalar prestashop desde cero en el dominio nuevo, ver si funciona y luego copiar la base de datos antigua y ver qué pasa.
skaparate escribió:Cuál es la estructura de tus carpetas? Tienes la tienda en una carpeta directamente bajo htdocs o todos los archivos de prestashop directamente en htdocs (o public_html u otro)? Además de la tienda tienes un sitio web en el mismo dominio?

P.D: Una solución es instalar prestashop desde cero en el dominio nuevo, ver si funciona y luego copiar la base de datos antigua y ver qué pasa.

Acabo de realizar las mismas operaciones que antes con una nueva instalación de prestashop y funciona perfectamente.

Voy a probar a cambiar el index o algo más y si no funciona pues redirigo la antigua base de datos a la nueva isntalación a ver que pasa.....por más cosas no se me ocurren.

GRacias
Buenos señores, pues no se como lo he arreglado, la verdad es que he tocado de todo, he instalado prestashop de nuevo, he intentado ponerle la base de datos de la antigua, me empezó dando error 500, luego no se que...al final, he intentado hacer una migración de nuevo siguiendo todo paso a paso y con mucho cuidado a ver si asi salia....y cuando estaba borrando la instalación nueva porque tampoco funcionaba.....de buenas a primeras me ha funcionado.

Asi que daoy el tema por cerrado.

GRacias Skaparate.
skaparate escribió:Que bueno que lo hayas resuelto :).

Que te vaya bien,

Saludos.

Muchas gracias.

Ya dio con lo que dió los problemas, lo dejo aqui por si alguien tiene elmismo problema que yo lo solucione, que de eso se trata, de que todos aportemos nuestro granito de arena.

Lo que le pasaba es que yo en mi hosting tenia SSL activado, hata ahi bien, lo que pasaba es que en el menú de configuración-Habilirar SLL lo tenia habilitado, y al ponerlo en deshabilitado funcionó todo correctamente, lo se porque lo he activado y ha vuelto a fallar, jejejejeje.

Ya no lo activo más!!!!!

Saludos